Skip to content

Category: Technology

Excel Search by Multiple Criteria

If you have a list of horizontal data and you want to turn it into vertical data then you need to use the index() function. As in the example below.

First, prepare a list of two non-repeating values, in my case “Nazwa” and “Kwota”. Then a list of recurring values to help with the search, I search by the “Etap” column.

The formula in the “Adres” column looks like this:

=WYSZUKAJ.PIONOWO(H2;A2:F10;2;0)
=VLOOKUP(H2;A2:F10;2;0)

Nothing special. The real magic begins after this column. Index() function supported by Match().

=INDEKS($A$2:$F$10;PODAJ.POZYCJĘ($H2&K$1&$I2;$A$2:$A$10&$C$2:$C$10&$F$2:$F$10;0);5)
=INDEX($A$2:$F$10;MATCH($H2&K$1&$I2;$A$2:$A$10&$C$2:$C$10&$F$2:$F$10;0);5)

Remember to confirm the index() function using the key combination Crtl+Shift+Enter.

The system doesn’t recognise the monitor

If you have problem wiIf you have a problem with your monitor, one day everything looks normal, the next day the screen resolution is 800×600 and the device manager defines your monitor as a “Standard PnP monitor”, this means you probably have a problem with the cable connecting the GPU to the monitor. 

Magic Mirror on Raspberry Pi 3B+

 

 

To have such an information monitor, you need to have some unnecessary things, like a monitor and a raspberry, and buy a monitor holder and an hdmi-dvi adapter. I had nothing, so I bought parts. For the monitor I went to a computer store and asked about an old monitor, they gave me a 17″ for free.

 

 

 

Steps in few words:

  1. Install Raspberry Pi OS with desktop
  2. Install MagicMirror
  3. Install modules:
    • MMM-homeassistant-sensors – sensors from Home Assistant (temp, pressure, humidity, pm2.5, etc.)
    • MMM-Spotify – shows some music playing on Spotify
    • MMM-Wallpaper – based on reddit or bing wallpaper changer
    • MMM-GooglePhotos – shows your albums
    • MMM-HTMLBox – shows weather from meteo.pl
    • MMM-SystemStats – shows rpi stats
  4. Autostart MagicMirror https://github.com/MichMich/MagicMirror/wiki/Auto-Starting-MagicMirror

If you don’t have money for a big memory card or you use a recycled one, you have to watch the memory so that MagicMirror logs don’t eat all the memory. I solved this by installing logrorate.

https://github.com/keymetrics/pm2-logrotate

with this settings:

https://dannnb.medium.com/pm2-large-log-files-and-how-to-remove-them-4bffb30e99dc

WordPress on Mikr.us v1

What requirements does WordPress have?

PHP version 7.4 or greater.
MySQL version 5.6 or greater OR MariaDB version 10.1 or greater.
Wsparcie HTTPS

https://pl.wordpress.org/about/requirements/

On older versions it will also work, but it is not recommended.

In the mikr.us panel, we check that the system we have installed is Ubuntu 16.

WordPress instalation

Using the link:
https://websiteforstudents.com/install-wordpress-on-ubuntu-16-04-lts-with-nginx-mariadb-and-php-7-1-support/   
we do the following:

Step 1.

Step 2 is skipped. We do not install the database, we will use a shared database, the access data is in the mikr.us panel. InstruBazy danych nie instalujemy, będziemy korzystać z bazy współdzielonej, dane dostępowe znajdują się w panelu mikr.usa. Manual: 
https://www.facebook.com/groups/mikrusy/learning_content/?filter=2830942186953036&post=256041555449185

Step 3. Install PHP 7.4 using the instructions at:
https://computingforgeeks.com/how-to-install-php-on-ubuntu/
Ad-on modules and final configuration take from the first ling changing 7.1 to 7.4

Step 4. Nope

Step 5 – 9. We follow the instructions. We get the data for database configuration from panel. And in nginx configuration change
unix:/var/run/php/php7.1-fpm.sock
to
unix:/var/run/php/php7.4-fpm.sock

That’s it, wordpress works and it’s great. Only the address is weak, because it looks like this: http://[1080:0:0:0:8:800:200C:417A].

If we have a domain then we can redirect it to mikr.us using the “Cloudflare i Mikrus” instructions:
https://www.facebook.com/groups/mikrusy/learning_content/?filter=2830942186953036&post=1155889001448056